[ARVADOS] updated: a5b4a7e8da51d84fe200d88dc39bd5431bb60a11
git at public.curoverse.com
git at public.curoverse.com
Thu Nov 6 10:43:42 EST 2014
Summary of changes:
.../app/controllers/pipeline_instances_controller.rb | 18 ++++++++++++------
1 file changed, 12 insertions(+), 6 deletions(-)
via a5b4a7e8da51d84fe200d88dc39bd5431bb60a11 (commit)
from 723afcb87896a7dcee99bb41b37ef368464f4f40 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
commit a5b4a7e8da51d84fe200d88dc39bd5431bb60a11
Author: radhika <radhika at curoverse.com>
Date: Thu Nov 6 10:42:07 2014 -0500
3177: try to partition input selection only if it is a string
diff --git a/apps/workbench/app/controllers/pipeline_instances_controller.rb b/apps/workbench/app/controllers/pipeline_instances_controller.rb
index ef97b1e..3c5c082 100644
--- a/apps/workbench/app/controllers/pipeline_instances_controller.rb
+++ b/apps/workbench/app/controllers/pipeline_instances_controller.rb
@@ -64,12 +64,13 @@ class PipelineInstancesController < ApplicationController
if component[:script_parameters]
component[:script_parameters].each do |param, value_info|
if value_info.is_a? Hash
- value_info_partitioned = value_info[:value].partition('/')
- value_info_class = resource_class_for_uuid(value_info_partitioned[0])
+ value_info_partitioned = value_info[:value].partition('/') if value_info[:value].andand.class.eql?'String'
+ value_info_value = value_info_partitioned ? value_info_partitioned[0] : value_info[:value]
+ value_info_class = resource_class_for_uuid value_info_value
if value_info_class == Link
# Use the link target, not the link itself, as script
# parameter; but keep the link info around as well.
- link = Link.find value_info_partitioned[0]
+ link = Link.find value_info[:value]
value_info[:value] = link.head_uuid
value_info[:link_uuid] = link.uuid
value_info[:link_name] = link.name
@@ -82,10 +83,15 @@ class PipelineInstancesController < ApplicationController
# to ensure reproducibility, the script_parameter for a
# collection should be the portable_data_hash
# keep the collection name and uuid for human-readability
- obj = Collection.find value_info_partitioned[0]
- value_info[:value] = obj.portable_data_hash + value_info_partitioned[1] + value_info_partitioned[2]
+ obj = Collection.find value_info_value
+ if value_info_partitioned
+ value_info[:value] = obj.portable_data_hash + value_info_partitioned[1] + value_info_partitioned[2]
+ value_info[:selection_name] = obj.name + value_info_partitioned[1] + value_info_partitioned[2]
+ else
+ value_info[:value] = obj.portable_data_hash
+ value_info[:selection_name] = obj.name
+ end
value_info[:selection_uuid] = obj.uuid
- value_info[:selection_name] = obj.name + value_info_partitioned[1] + value_info_partitioned[2]
end
end
end
-----------------------------------------------------------------------
hooks/post-receive
--
More information about the arvados-commits
mailing list